I do not see the pulished version after publishing an asset

Discussions related to assets & shots including associated elements and files.
Post Reply
sean
Posts: 1
Joined: March 20th, 2018, 7:09 pm

I do not see the pulished version after publishing an asset

Post by sean »

Hello,
I am looking through the tutorial video, and I am stuck in the part where when I publish a new asset, and I do not see the asset version with filter-pulished on.
This screen shot is with filter-work,
Screenshot_5.png
Screenshot_5.png (155.5 KiB) Viewed 591 times

This is filter-published on which you do not see the master published file.
Screenshot_6.png
Screenshot_6.png (148.88 KiB) Viewed 591 times
and you can see that NIM is not creating a master published file in the folder structure.
Screenshot_7.png
Screenshot_7.png (9.51 KiB) Viewed 591 times
Please help me to fix this.
Thanks for reading!

User avatar
andrew
Site Admin
Posts: 301
Joined: June 24th, 2014, 8:10 am

Re: I do not see the pulished version after publishing an asset

Post by andrew »

Hi,

It appears that the symbolic link to the published file wasn't created. There's a few things to check:

What OS is your project server? The symbolic links to the published files are only created on linux and osx file servers. If you are using a windows based file server uncheck the "SymLink" checkbox when publishing from the connector. This will create a copy of the file instead of a link. Currently Asset Masters require the use of links so those will be unavailable on a windows based file server. We are changing this behavior to support windows file servers that can not create links.

Are you using the VirtualBox Shared Folders to mount the project server on the VM? VirtualBox sometimes has issues with creating symbolic links when using a windows host. If this is the case and NIM is failing to create the link we can remount your file server using the fstab file.

Additionally, Windows needs to be told to read symbolic links. Can you login to the VM console and navigate to the ASSETS/Mary/RIG location and see if the link exists? If the link exists but you can not see it on the Windows workstation odds are you need to enable your workstation to see the links. To check if symbolic links are enabled, from an Administrator command prompt enter the following:

Code: Select all

fsutil behavior query SymlinkEvaluation
If links are enabled you should see the following:

Local to local symbolic links are enabled.
Local to remote symbolic links are enabled.
Remote to local symbolic links are disabled.
Remote to remote symbolic links are enabled.


If they are not enabled run the following line in an Administrator command prompt:

Code: Select all

fsutil behavior set SymlinkEvaluation L2L:1 R2R:1 L2R:1 R2L:1
Let us know if you fall into any of these cases...
Andrew

radu@flyingmonk.com
Posts: 1
Joined: March 22nd, 2018, 6:08 pm

Re: I do not see the pulished version after publishing an asset

Post by radu@flyingmonk.com »

Hi Andrew

The server is a Mac running Sierra 10.12.4
I ran the commands in order to enable the links on the workstation and now all 4 are enabled. Should one of them to be disabled?
However it still does not work.
Please if you'd like email me to radu@flyingmonk.com and I will give you the Teamviewer credentials to look on the server.

Radu

User avatar
andrew
Site Admin
Posts: 301
Joined: June 24th, 2014, 8:10 am

Re: I do not see the pulished version after publishing an asset

Post by andrew »

Hi Radu,

All four link types should be enabled. The output I included was just an example.

If you can confirm that the file does not exist when navigating to the location from the VM console then it may be an issue with VirtualBox. VirtualBox limited symbolic link creation in later versions with specific OS hosts as a security measure. There are two options to resolve this.

The first options is to use the fstab instead of Shared Folders to mount servers. To do this, edit the /etc/fstab file and provide the mount credentials. Here is a link to the NIM documentation on adding a permanent link in linux:

http://nim-labs.com/docs/NIM/html/serve ... unt-points


The second option is to turn on symbolic links for VirtualBox. Here is the command to execute on your OSX host. First shut down VirtualBox and then execute the following command from a terminal.

Code: Select all

VBoxManage setextradata VM_NAME VBoxInternal2/SharedFoldersEnableSymlinksCreate/SHARE_NAME 1
Where "NIM" is the name of my VM (VM_NAME) in VirtualBox and "PRJ" is the name of my Shared Folder (SHARE_NAME).

Example: VBoxManage setextradata NIM VBoxInternal2/SharedFoldersEnableSymlinksCreate/PRJ 1

Note: If VBoxManage is not in your path you may need to navigate to the VirtualBox folder containing the executable.

When you restart VirtualBox, the guest OS should be able to create symbolic links on the Shared Folder.

I will email you separately from support@nim-labs.com if you would like to schedule a Teamviewer session.

Thank you,
Andrew

Post Reply